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Introduction 

The F3D measurement data processing software is software for filtering and 

visualizing measurement results outputted from the ODiSI. 

The F3D software consists of a 3Dviz tool for 3D visualization and a filter tool for 

filtering. 

 

There are two main ways to visualize data from ODiSI control software. The first 

method is to visualize the 3D in real time. The first method is to sequentially view the 

measurement results that are streamed. The second method is to use the 

measurement result file (tsv file) outputted in the ODiSI controllers after the 

measurement is completed. 

The flow of each method is as follows. 

 

[Real-time visualization] 

 

 

[3D Visualization using recorded file] 
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 3Dviz Tool Overview 

The 3-D visualization tool "F3D 3Dviz" is a software that allows real-time visualization 

of measurement data and animation creation from visualization of historical 

measurement data using photographs or 3D models of measurement objects. Since 

the measurement data at multiple points can be visualized at once, it is possible to 

easily grasp the phenomenon and the measurement state. 

 

1.1. Launch software 

Double-click the 3Dviz icon  or select 3Dviz from the Windows Start menu. 

For information about installing software and activating licenses, please read F3D 

Installation Guide. 

 

1.2. 3Dviz GUI 

F3D 3Dviz GUI is classified into three area. 

Model view area Main area in which the visualization results are displayed. 

Right-click in the area to display context menu. 

Tabs area Upper-left corner. Including Contour tab and Routing tab. 

2D graph area Lower-left corner. 2D graph of that time is displayed. 

 

F3D 3Dviz GUI 

Model view area 

2D graphs 

Tabs area 
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1.3. Tabs area 

There are two tabs in the Tabs Area: "Contour" and "Routing" tabs, and you can 

switch between tabs depending on the task. For details on how to operate each tab, 

please refer to the briefing of the corresponding operation. 

 

Contour tabs 

Configuring connections with ODiSI controller for real-time visualization, 

Playback control can be performed when reading the measurement result file. 

 

Routing tabs 

You can configure fiber routes after switching to the Routing tabs. 

The table in the Tabs Area shows the channel number of the selected fiber route and 

the fiber position of each node, which can also be edited. 

 

1.4. Context menu 

Right-click in Model View Area to display the context menu and perform various 

operations. For instructions on how to use each menu, please refer to the instructions 

for each operation. 

Image… Imports an image of an object to be measured 

Stl… Import STL 3D model of the object to be measured. 

FiberLocation… Save and load fiber location information 

View… Save and load view settings 

TriaSetting… Changes View settings of 3D model 

ContourSetting… Changes the color and range of the contour, the presence 

or absence of the contour, and the fiber display thickness. 

PlaybackSetting… Imports, sets, and outputs moving images of past 

measurement data 

ViewSetting… Changes the screen size of the model view area. 

Launch FilterTool… Launch FilterTool. 

Launch SpectralShift 

to Temperature Tool 

Launch application tool to convert spectral shift data to 

temperature data 

About… Show software version information 
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 Fiber route configuration 

This chapter describes how to load images and 3D models of the measurement 

object, set the fiber path, and set the fiber position. 

 

2.1. Importing 3D Model and Image 

Loads an image or 3D STL model of the objects that you want to draw fiber routes. 

 

 Importing image 

 Right-click on model view area and select “Image"→"load”. 

 

 Select and open the image you want to import. For the 

format of images that can be 

read .bmp, .png, .jpg, .jpeg, .tif, .tiff. 

 

 Importing 3D Model 

 Right-click the Model View area and select “Stl”→“load”. 

 Select and open the STL file that you want to import. 

 

 

 

 View operations in Model View Area 

 

Left drag Model rotation 

Right drag Model translation 

Wheel scrolling Zoom-in/ Zoom-out 

Middle click Set the Rotation Center 

Right-click Open context menu 
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2.2. Drawing fiber route 

This section describes how to draw fiber routes on 3D model. 

You can also draw fiber routes on images in the same way. 

 

The fiber route is drawn by first creating a point on the fiber route and then connecting 

the created points by a line segment, as shown in the procedure below. 

 

 Switch the Tabs Area to the Routing tab 

 "Ctrl + left-click" to generate a point (first point generation) 

※ If the point is hard to see, resize the point by referring to Changing the 

Contour Color (Contour Setting). 

 Generate a second point in the same way as in (2). 

 "Ctrl + left click" a generated green point to make it yellow selected status (1st 

point selection). 

 "Ctrl + left-click" the other green point (select the 2nd point, create a line segment) 

 

How to create, edit, and delete points and line segments is as follows. 

 

List of operations when creating fiber routes 

When nothing is selected 

Operation Target Behavior Changes in the screen 

Ctrl + left-click 

STL 
Generate 

point 

 

Line Insert point 

 

Point Select point 

 

Ctrl + right-click 

STL -  

Line Delete line 

 

Point Delete point 

 

When a point is selected 

Ctrl + left-click 

STL Move point 

 

Line Insert Point 
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Point 
Generate 

line 

 

Ctrl + right-click 

STL Deselect 

 

Line Deselect  

Point Deselect  

 

 

For fiber routes, please draw only the route used as the measurement area(sensor). 

You do not need to draw routes which is not for measurement. 

For example, a single fiber line as shown below→Takeover→If the fiber is stretched 

like a straight line, only the straight-line section is drawn. 

 

 

 

 

  

Measuring region 

Actual fiber route Fiber routes to draw 
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2.3. Fiber Location and Channel Number Settings 

After drawing a fiber route, assign a channel number to each fiber route and register 

fiber position information for each point (how many m positions each point is in the 

fiber). 

 

To set the fiber route, select the fiber route → enter the channel number → enter fiber 

position information for each point. 

 

 Switch to Routing Tab. 

 Select a green point on the fiber route by Ctrl and left-clicking. 

 

When Fiber Route is selected, Tabs Area displays the channel number of the selected 

Fiber Route and the location of each point. 

 

Channel:   Fiber Root Channel Number 

Location(mm):  Location of points 

        0 is the default value before input. 

 

A blue highlighted row in the list indicates that the point is 

selected and corresponds to the yellow point in Model View 

Area. If you select a different row (different point) on the list, the 

corresponding yellow point is selected in Model View Area. 

 

 Enter channel number of the route in the Channel field. 

When you enter a channel number, the Fiber route changes its display color 

according to the channel number. 

 

 Enter the location of each point you saved when preparing for measurement. If 

there is a point whose location information is unknown, please enter only the 

location information of the start and end points of the fiber route. 

 

 (Only when location information is unknown) 

Clicking Re-interpolate automatically interpolates the location(mm) of each point 

according to the location of the start point and the end point and the fiber route 

length on the model. 
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2.4. Saving and loading fiber routes 

Drawn fiber routes and fiber route settings can be saved to a file and reused. 

 

 Preserving fiber routes 

 Right-click in Model View Area and select FiberLocation→Save. 

 Specify the destination and file name to complete the save. 

 

 Loading Fiber Routes 

 Right-click in Model View Area and select FiberLocation→ Load. 

 Select the fiber location file (.fld) to load. 
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 Drawing setting 

This section describes how to change the drawing settings for each area. 

 

3.1. Changing view settings of 3D Model (Tria Setting) 

To open tria view configuration, please right-click in Model View Area and select 

TriaSetting from the menus. 

 

 

Changing Color of 3D models 

To change surface color of the 3D model, click the color box next in the Tria area and 

select a color from the color palette. 

 

   

 

Changing Transparency of surface 

Transparency of 3D model can be changed with Transparency bar in Tria area 

 

High Low 
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Show / Hide Wireframe of 3D models 

Fill in a check box to show wireframes of 3D models. 

 

 

To change colors of wireframes, please click 

color box in WireFrame area and select a color 

from color palette.  

 

Enter an arbitrary value for the thickness of the 

wireframe in the text box next to Width: . 

 

 

 

  



                        F3D 3Dviz users guide 

 

 15 
 

3.2. Changing Contour Colors (Contour Setting) 

 Right-click in Model View Area and select TriaColorSetting from the menus. 

 

 

 

 

 

 

 

 

 

 Enter each parameter, select it, and click OK. 

  

 

 

 

 

 

 

 

 

 

 

 

 

3.3. Saving and Importing Drawing Conditions (View) 

 

Save Drawing Conditions 

 Right-click in Model View area and select 

View➔Save from the menus. 

 Specify and save the destination and file name. 

 

 

 

 

 

Contour Parameter 

Thickness Fiber Route Point and Line Segment 

Thickness (Size) 

Max Maximum value of the contour 

Min Minimum value of the contour 

Colormap Type of color scheme for the contour bar 

Select from [HSV] [JET] [COOL] [HOT]. 

ShowContourBar Displayed On/Off of the contour bar 

Fontsize Contour Bar font size 

Unit Unit to be displayed in the converger 

[micro strain] [deg C] [GHz] 
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Importing Drawing Conditions 

 Right-click in Model View area and select 

View➔Load from the menus. 

 Specify and read the drawing condition file (.fvw 

file) to be read. 

 

 

 

 

 

 

 

 

3.4. Configuring 2D Graphs (Chart Setting) 

You can set the minimum and maximum values for the horizontal and vertical axes for 

2D graph area. 

 Right-click in the 2D graph area and select ChartSetting. 

 

 Enter maximum and minimum values for each axis and click OK. 

Click the Fit button to fit the currently loaded data. 

 

 

 

Automatically fit to data 

Maximum Minimum value input for each axis 
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 Real-time 3D visualization 

With F3D 3Dviz tools, you can 3D visualize measurement data streamed from the 

controller in real time by connecting the F3D installed post-processing PC and the 

ODiSI controller PC by TCP/IP. 

This section describes how to set up connections with ODiSI controllers after you 

have set up fiber routes and drawing conditions, and the drawing screens after the 

connections. 

 

4.1. Connect the PC to the LAN 

There are two methods of connecting the post-processing PC and the measurement 

control PC to the LAN: direct cable connection and connection to the same network. 

 

 Connect directly to the LAN cable 

Connect the post-processing PC and the measurement control PC directly with a 

LAN cable. This connection method is recommended because of the ease and the 

stability of the connection. 

 

 

 Connecting Two PCs to the Same Network 

When the ODiSI controller PC and the post-processing PC are located at different 

location or difficult connect them directly, you can establish connection by 

connecting the two PCs to the same network. 
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4.2. Set the IP address 

Set the IP address (IPv4) of each PC. 

To connect two PCs directly with a LAN cable, use the same value up to the third digit 

of the IP address and assign another number to the fourth digit. 

 

IP Example of Address Setting 

 ODiSI Controller PC Post-processing PC 

IP address 192,168.1.1 192.168.1.2 

Subnet mask 24 255.255.255.0 

 

When connecting via a network, set the connection according to the network you are 

using. 

 

 Setting IP address of ODiSI Controller  

 On the left-hand task bar, click System Setting. 

 

 Open Networking Settings by clicking Network Icons 
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 Select “Wired” from the left-hand list. 

“Wired” is not displayed unless a LAN adapter is connected to the PC. 

 Turn on the upper-right Wired button 

 Click the lower right Options to open Advanced Settings. 

       

 

 Select the IPv4 Setting tabs 

 Select "Manual" from the Method pull-down menu. 

 Click the Add button 

 Enter "24" in the "192.168.1.1" Netmask in the Address. 

 Clicking Save to complete the settings 
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 Set the communication of the ODiSI controllers. 

Use “Streaming Properties” to stream externally on ODiSI controller.  

This section explains how to easily set streaming properties. Check the ODiSI 6100 

User Guide for more information about the properties menu. 

 

 Open “Streaming Properties” tab. 

 Check the “OMSP Enable” to enable external streaming. 

(OMSP= ODiSI Measurement Streaming Protocol) 

 Check the IP address and port number. 

Required for F3D connection setup. 

 

 

 

 Configure the F3D software 

 

Complete the network settings for the post-processing PC. 

 Enter the IP address of ODiSI controller PC (IP checked 

above) 

 In the same way, enter the destination port number in the 

Port. 

 Connect by clicking the Connect. 

If the connection fails, make sure that streaming is 

enabled on the ODiSI controllers, that the measurement 

is started, and that there are no problems with the 

network connection.  

192.168.1.1 

Enable Check the address and port number 
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4.3. Real-time visualization screen 

When the measurement data is streaming from the ODiSI controllers after the 

connections are established, the display is automatically updated according to the 

measurement data. 

 

• Measured values are represented by color contours on the drawn fiber. 

• You can freely change the view even during real-time visualization. 

• Adjust the upper and lower limits of the contour, check the presence or 

absence of a contour, and check the thickness of the fibers from the right-click 

menu ContourSetting. 

• The 2D graph area displays the measured data of the channels with the 

horizontal axis as the distance in real time. 

• Click Disconnect to stop updating screen. 
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 Visualize measurement result files in 3D 

Using the playback function, you can read past measurement data, visualize it, and 

export a moving, images. 

 

5.1. Reading measurement data (Playback Setting) 

Measurement data format that can be read is the .tsv file ex by the ODiSI controller or 

the txt file output by Filter Tool. Use full.tsv for tsv files. You cannot use gages.tsv. 

Specify the measurement data using the PlaybackSetting that can be opened from the 

right-click menu. 

 

Playback Setting window 

 

  

PlaybackFiles Selection of measurement data ( full.tsv, .txt) to be referenced 

BaseDate Setting Movie Reference Time 

TimeBegin Setting movie start time 

TimeEnd Setting Movie End Time 

TimeInterval Setting the frame advance time interval 

IntervalNum View Frame Count (automatically set by TimeInterval) 

Click for each channel to select measurement data 

Unload read data 

When you click Pull, a value 
automatically input to fit measurement 
data. 
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5.2. Play Measurement Data 

The read measurement data can be played back in the Contour tab area. 

You can also control frames by using the play control buttons or by dragging the seek 

bar. 

 

 

  

Time[sec] Displaying Playback Time 

Date Display of the reference time 

PlaySPF Seconds Per 1 Frame 

＞ Playback start button 

[ ] Stop button  

＜－ Back frame button  

－＞ Forward frame button  
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5.3. Exporting Movies and Images 

You can export movies and images in the Playback Setting window 

 

 Click ExportMovie button at the bottom left of the Playback Setting window. 

 

 

 

 

 Specify location for exporting in TargetDirectory.  

 Select a format of Images in the FileFormat pull down menu 

 To export images of individual frames, check the "ExportImages" check box and 

enter a prefix in "FilePrefix". 
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 Check "ExportMovie" to export a movie. 

 Specify the location for exporting and filename of movie in the ExportMovieFile. 

 Specify the FPS of the movie to export (0 to 250, usually less than 30) 

 To delete an image used when generating a movie, check "DeleteUsedImages". 

 Click Export to open Videos Compression Settings window. 

 

 

 

 Select a compressor (typically using Microsoft Video 1) 

 Click OK to start the export. 
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 Filter Tools 

6.1. Overview 

The F3D filtering tool is an application tool for eliminating noise during measurement 

and dividing and extracting measurement data by graphing the Strain quantities and 

temperature distributions of measurement data in three dimensions. 

By filtering the noise processing while checking the data on the three-dimensional 

graph, you can easily understand whether the noise processing is performed properly. 

It is also possible to analyze in more detail by displaying a two-dimensional graph or 

measuring dimensions at an arbitrary position. 

 

6.2. Launch Filter Tool 

Right-click in the F3D 3Dviz Model View area and click Launch Filter Tool to launch 

the filter tool. 

 

The filter tool consists of four display areas: the , the 2D Area, the Filter Area, and the 

Graph Control Area.3D Area 

                  

 

 

3D Area 

Filter Area 

Graph 

Control 

Area 

2D Area 
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6.3. Input/output of measurement result file 

From the File menu, you can check the file information. Select [File] to open the 

following menu bar. 

 

[Open] : Open the text (.txt), CSV, and.tsv files of measurement data. 

[Save] : Save the filtered data in text (.txt) or CSV (.csv) format. 

[Export selected region] : Outputs data within the range selected in the 2D Area. 

[File information] : Show the information of the read measurement data. 

[About] : Show the About window and display the versions of the filter 

tool software. 

[Quit] : Exit the filter tool software. 
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 Reading the Measurement Result File Including NAN 

By ODiSI-6100, the measured values for low-quality Fibre Sensors are 

Output with the string [NAN] embedded. 

 

The F3D filtering tool cannot read data including NANs directly, and an error message 

as shown below appears. 

To read a file, you must convert it once to a file that does not contain NANs, and then 

reload the converted file. 

 

         

 

When you click OK , the window for converting the file as a.txt file opens. Enter an 

arbitrary name and save it. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Save to open the window for data conversion, and you can select two 
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conversion methods. 

 

 

Interpolate [NAN] from previous and next data 

Linear interpolation is performed from the previous or 

next time or gage value. 

Select [Time][Length] for linear interpolation and click 

OK to save the interpolated data. 

 

 

 

 

Replace [NAN] with a fixed value 

Replaces all NANs with the user-specified value and 

reads it. 

After entering the replacement value, click OK to save 

the data with NAN replaced by the fixed value. 

 

 

 

After saving the interpolated/replaced data, select [File] on the menu bar and press 

[Open] to load the saved data. 
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 File information 

Shows information of the opened measurement data. 

The unit is displayed in the opened text file (.txt). In the following example, the length 

unit is [m] and the time unit is [sec]. 

 

 

 

Length : Minimum/Maximum Fiber Length Output Range 

Time : Minimum value and maximum value of measured time 

Value :Minimum value and maximum value of 

Strain/temperature/shift amount of measured data 

Size :Number of samplings in the lengthwise and temporal 

directions of the measurement data and the total. 

Interval :Length sampling interval [m] and time sampling interval [sec] 

of measurement data 
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 About 

 [About] window shows you the version of the filter tool software. 
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6.4. Operating 3D Graph 

 

 Changing view position 

When the measured data is read in, the data measured by the ODiSI is displayed as a 

three-dimensional graph in the [3D Area]. The color is a contour according to the 

measured value. By default, the value closer to the maximum value is displayed in 

red, and the value closer to the minimum value is displayed in blue. 

 

Mouse operation 

Operation Behavior 

Ctrl + left-click Point selection 

Ctrl + left-drag Rotating a 3D Graph 

Ctrl + right-drag Translation of a 3D graph 

Ctrl + Wheels Scaling 3D Graphs 

"F" key Screen fit 

Left-click Select a point in the vicinity. 

Translation and scaling operation are same in 2D area. 
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6.5. View setting 

The view setting is used to set how to draw a three-dimensional graph. 

You can specify the range of the three-dimensional graph, adjust the contour range 

and size, and display the cross-section graph displayed in the Filter Tool Control 

window. 

 

       3D Area : Displays three-dimensional graph of the measurement data 

       2D Area : Displays the top view of the three-dimensional graph in two 

dimensions. 

 

 Changing the Graph Scale 

The scale for each direction changes in the graph control area. This value is entered 

directly and immediately applied. Scaling is used when the displayed length (X), 

measurement time (Y), or grandest value (Z) is not suitable for measurement data. By 

adjusting the scale, you can view the graph of the measurement data in more detail. 

Note: X, Y, and Z are set to 1 by default. 

3D Area 

2D Area 

Analysis tool control window 
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If the measurement time is extremely short for fiber lengths and measurements and 

the graph contrast is not balanced, changing the time direction (Y) scale makes the 

graph easier to see. 

 

 Selection of the drawing area 

Procedure for selecting a rectangular area 

By selecting the area of the white rectangle displayed in the 2D Area, 

You can change the display range of the 3D Area. 

 

 

[left dragging] to select a rectangular area on the 2D area. A rectangle for selecting a 

range has been displayed since the 3D graph was opened, and the rectangle is used 

to select the range. 

The graphs selected in the range can be output to a text file (.txt) or a CSV file (.csv) 

from [File] → [Export Selected Region] on the menu bar.  

Selected area 
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 Contour Range 

The contour of the 3D point cloud graph indicates the measurement value for each 

point.  

By adjusting the contour range, you can color-code the displayed data graph in whole 

or in part to see the measurement value roughly or in detail. 

 

Procedure for changing the contour range 

Select [Contour range] from [View] on the menu bar to open [Contour Setting]  

       

Select [Fit to Data] to automatically set the upper and lower limits to the maximum and 

minimum values of the measurement data.  

Change the upper and lower limits if you want to set fixed value. 

 

  

Three-dimensional Two-dimensional 
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 Axis Label Setting 

Changes the axis labels (Axis Label) displayed in the 3D area. 

6.5.4.1. Changing Scale of Axis Labels 

Select [Axis Label] from [View] on the menu bar to open [Axis Setting] window. 

 

 

 

[Length] : Set X axis label (fiber length direction). 

[Time] : Sets Y axis label (time direction). 

[Value] : Sets Z axis label(Measurement value direction). 

 

[min] : Sets the minimum value to be displayed on the axis label. 

[max] : Sets the maximum value to be displayed on the axis label. 

[Origin] : Sets the intersection position of the axis labels. 

[tics] : Sets the scale interval displayed on the axis label. 

[Fit to Data] : Fits the intersection of the axis labels to the measured data. 

[Fit to Trimming] : Fits the intersection of the axis labels to the display area. 

[Axis Label] : Set the axis label name and switch between display and non-

display. 
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6.5.4.2. Example of the procedure for changing the axis label (X axis) 

Changes the display range of the graph values on the X axis (length direction). 

 

 

Changing the value of the length changes the display of the X-axis scale. 

For [min], enter the minimum value of the axis label to be displayed. 

For [max], enter the maximum value of the axis label to be displayed. 

 

In the above figure, the initial value was [0 to 0.86], [min] is changed to [0.5] and the 

value of [0.5 to 0.86] is displayed, the scale of [0 to 0.49] is hidden. After setting the 

value, click [Apply] and [OK] to change 3D area. 

 

You can also set [Time] and [Value] in the same way. 
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6.5.4.3. Example of procedures for changing axis labels  

       (Change intersection of axes) 

Manually Changing 

Changes the display position of the axis label in the 3D Area. 

By entering a number in the [Origin] of the [Length][Time][Value] in the [Axis Setting] 

window, the position where the axis labels are displayed can be moved up, down, left, 

and right. 

 

 

 

 

Fit to data Automatically 

[Fit to Data] to move the axis labels to the appropriate position and show all range of 

data. 

 

Before moving the axis label After moving the axis label 
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Fit to Trimming area 

To fit the axis labels to the trimmed area, click [Fit to Trimming] button in the [Axis 

Setting] window. The axis labels that were fitted to the hidden part of the graph will fit 

to the displayed 3D graph. 

] 
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6.5.4.4. Example of the procedure for changing the axis label 

    (Changing axis label name) 

From the [Axis Setting] window, set the name of the axis label and whether the axis 

label is displayed or not. 

You can open [Axis Label Setting] window by clicking [Axis Label] button in the [Axis 

Setting] window. 

 

Checking [Visible] in the [Axis Label Setting] window displays the names of the axis 

labels in the 3D graph 

When you enter a label name in [Axis Label], the name of the axis label is changed. 
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6.5.4.5. Example of the procedure for changing the axis label  

     (Changing scale interval) 

Set the axis label scale interval in the [Axis Setting] window. 

Click the [Axis Label] button in the [Axis Setting] window to open the [Axis Label 

Setting] window. 

 

Enter the scale interval of the axis labels in [tics] of [Axis Label Setting]. 

 

 

Although the default value of [tics] was displayed as 0.2, changing the value to 0.05 

increases the scale in the length direction (X) and allows you to check the value in 

more detail. When [px] is checked, the [tics] values switch to pixel-by-pixel displays. 
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 Cross-Section display 

6.5.5.1. Procedure for displaying cross sections 

Show Cross-section of the 3D graph 

Right-click on graph to open context menu. 

 Select [Add X-Z Section] to view the cross section in the X-Z orientation. 

 Select [Add Y-Z Section] to view the cross section in the Y-Z orientation. 

 

 

 

When you create cross section in 3D graph, the [Section View] Window opens at the 

same time. You can also open the [Section View] window from the [View]→[Section 

View] menu. 

 

  

"Add Y-Z Section" Display of cross section menu 
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Information and Settings of cross sections 

Checking the position of the cross section and setting whether to display or hide the 

cross section in the [List of Cross Sections] (lower right diagram) of the [Graph Control 

Area]. 

 

[Axis] X : Displays the cross section in the length direction (X-Z). 

      Y : Displays the cross section in the time direction (Y-Z). 

[Value] X : The position where the cross section is cut in the length of 

the fiber. 

 Y : The position where the cross section is cut in the 

measurement time direction. 

[M(Main)]  :Show/Hide in "3D Area" 

[T(Top)]  : "Display/hide in 2D area" 

[S(Section)]  : Show or hide in the Section View window. 

[Col(Color)]  : Color of cross section 

[Line]  : Matrix number of measurement data (X: Column/Y: Row) 

 

Movement of cross section display 

When the displayed cross section is left-clicked, the cross section is selected and its 

color changes. Right-click and select Move Section. Move the mouse without pressing 

anything to move the cross section. 
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To determine the cross-section position, left-click the black background in the 3D area 

to change the cross section color to red, which is determined. If you decide the 

position, the cross-section will not move. 

 

BMP (Image) Output of Cross Section Graph 

Clicking [Export]→[Image] → [Bmp] in the menu bar in the cross section graph 

window allows you to specify the output destination and output the graph images 

in.bmp format. 

 

 

CSV and TXT (Text) Output for Cross Section Graphs 

From the menu bar in the cross section graph window, click [Export] → [Data] → 

[Csv..] or [Text..] to specify the output destination and output the numerical data of the 

graph in .csv format or .txt format. 

Output Graph as Image 
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Text-out by clicking Csv or Text 
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6.5.5.2. Cross-sectional graph 

You can create a two-dimensional graph (cross-sectional graph) at any point in the 

three-dimensional graph. In the [Section View Window], it can be displayed in the Y-Z 

direction (Time) or the X-Z direction (Length). 

You can also print graph images in bitmap format and graph data in csv format. 

 

How to operate on a cross section graph 

Wheel rotation Changes the display range of the cross section 

graph. 

With the wheel held 

down 

Move the mouse 

Scroll up, down, left, and right across the screen 

of the cross section graph. 

 

Display operation in the cross-sectional direction 

In the [Section View Window], the cross section in the Y-Z direction is displayed as 

[Time] and the cross section in the X-Z direction is displayed as [Length]. 

 

[Length] Length[m]  : Length display range 

 Z axis range Strain/Temperature/Frequency Shift Display Range 

[Time] Time[sec] : Display range in the time direction 

 Z axis range Display range of Strain/temperature/frequency shift amount  

Add Y-Z Section 

Time 

Add X-Z Section 

Length 
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Changing the Graph Format (Lines and Points) 

You can select the display style of the graph from the lines and dots. 

Line : Line display 

Point : Point indication 

You can change the line thickness and point size by entering a numeric value in 

[DrawSize]. 

 

 

 

 

 

 

 

 

 

Axis Label Change (Display of Axis Label Name) 

Set the name and whether to show or hide the axis labels in the Section View window. 

Clicking [Setting]→[Axis Label] in the [Section View] window displays the setting 

window. 

 

 

Checking [Visible] in the [Axis Label Setting Window] displays the name of the axis 

label in the cross section graph. 

Entering a label name in Axis Label in the Axis Label Setting Window changes the 

name of the axis label. 

 

Line Point 
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When [Rotate 90 degrees counter clockwise] is checked, the values are rotated by 90 

degrees. 
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Axis Label Change (Memory Interval) 

From the Axis Label Setting Window, set the scale spacing for the axis labels. 

Click Setting]→[Axis Label in the Section View window to open the Axis Label Setting 

Window. 

 

 

You can change the scale intervals of the axis labels by entering a number in [tics] of 

[Axis Label Setting Window]. 

When [px] is checked, the [tics] values switch to pixel-by-pixel displays. 
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6.6. Adding points 

By adding a point on the three-dimensional graph, you can measure the distance 

between two points, display the cross section on the point, and set the rotation center. 

 

 Point selection 

You can add points by selecting Add Point in the Data menu bar or by clicking Ctrl and 

left-clicking on the three-dimensional graph. The selected point turns blue and the 

other points turn purple. 

 

 

 Point selection menu 

Right-click an added point to select it and turn it to blue and display the menu. 

 

 

[Add Y-Z Section at Point] : Create a cross section in the Y-Z direction. 

[Add X-Z Section at Point] : Create a cross section in the X-Z direction. 

[Delete Point]   : Deletes a point. 

[Rotate Center]   : Set to the rotation center. 
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 Distance between two points 

        

 

With the two points you want to be distanced, select Data]→[Distance on the menu 

bar, and select the two points with Left-Click. The reference point changes to blue, 

and if you select another point, a window is displayed, showing the dimensions in the 

X-axis Y-axis Z-axis direction. 
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6.7. Filter function 

F3D filters can read text data in ODiSI format (.tsv) and filter out the text data under 

certain conditions. Filtered data can be printed in text data (.txt) or in CSV files (.csv). 

Filters act on each point depending on its value and its relationship to surrounding 

values. Filtered history remains at the beginning of the file. 

Cutoff Removes data that is outside the specified 

threshold and linearly interpolates between 

previous and next time values 

Median For each point in the two-dimensional data, sort the 

values in the specified range around the point in 

order of size, and apply the value (median) of the 

point in the center. 

Short Wavelength Cut Removes frequency components higher than the 

specified frequency. This can be set in either the 

temporal or spatial directions. 

Change cutoff If the value changes by more than the specified 

amount of change compared to the previous value, 

the previous amount of change is applied. 
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 Viewing the Filter Dialog 

When using the filter function, select [Add] in [Filter Areas] to open the [Filter Control] 

dialogue box. 

 

 

[Cutoff]    : Switches to the cutoff filter. 

[Median] : Switches to median filter. 

[Low Pass]  : Switches to the short wavelength cut filter. 

[Variation Cutoff]  Change: Changes to the cutoff filter. 

 

[Direction]   : Specify the filter direction (not required for Median) 

[Iteration]  : Specify to overlay similar filters (short wavelength) 

 Not required for cuts.) 

[Range]   : specifies the range to filter. 

[Full]  : The range is adjusted to the entire range of the 

measurement data. 

[Trimmed] : Fits the range to the specified range in the 2D area. 

 

[max]   : Depends on the filter. 

    Refer to each filter page. 

[min]   : Depends on the filter. 

    Refer to each filter page. 
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 Cut-off filter 

The cutoff filter traverses the data at each fiber position in chronological order, deletes 

data outside the specified threshold, and linearly interpolates between the previous 

and next values. This is used when the value of the generated noise is far from the 

actual value. 

 

6.7.2.1. Cut-off Filter Settings 

 

[max] : Upper threshold. Points above this value are cut-off studies. 

[min] : Lower threshold. The points below this value are the cutoff targets. 

 

Example 

 

Graph at left   :Raw Data 

Graph to the right : Filtered Data (min = -500,max = 800) 

Large noise is eliminated, but values within the threshold are left as they are. 
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 Median filter 

The median filter is a technique often used for image processing, which looks at the 

values in a specified range around each point in two-dimensional data, sorts the 

values in order of size, and applies the values (median) of the points located in the 

center of the sorted values. This process eliminates noise that can cause extreme 

values to appear at only one point. 

 

6.7.3.1. Median Filter Settings 

 

[Step Length] : specifies the target range for the length direction. In the case of [2], 

the target data ±2 

A total of five data items are available. 

[Step Time] : specifies the range of interest in the time direction. 

 

Median filter example 

The following is a case where the values are applied around a certain point with a 

value of 1024 and within the range of 1 before and after each point in the time 

direction. This range of data is ordered 1.1, 2.2, 2.3, 2.5, 4.3, 5.4, 5.5, 6.4, 1024.0, 

and is replaced by the fifth data 4.3, which is the center of the nine data. 

 

1.1 5.4 2.3  1.1 5.4 2.3 

2.5 1024.0 6.4  2.5 4.3 6.4 

4.3 2.2 5.5  4.3 2.2 5.5 

Before 

application 

 After 

application 
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 Short Wavelength Cut Filter 

A short cut filter is a filter that removes frequency components that are higher than the 

specified frequency and is suitable for removing fine noise. A low-pass filter is also 

called a low-pass filter to transmit a long wavelength. 

 

6.7.4.1. Configuring Short Wavelength Cut Filters 

 

[Wavelength] Specifies the length of the wavelength that will be the threshold. For 

wavelengths shorter than this wavelength 

   You reduce. 

 

Example of Short Wavelength Cut Filter 

The following data is obtained by applying the short wavelength cut filter of 0.05sec, 

0.1sec, and 0.5sec. 

 

 

Original data 0.05 sec filter 

0.1sec filter 0.5sec filter 
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 Change cutoff filter 

Variation cutoff filter uses the amount of change in the measurement data as a 

threshold value to reduce noise for portions having a sudden change. It is suitable for 

eliminating small pulse noise in large changes. 

 

6.7.5.1. Change Cutoff Filter Settings 

 

[Threshold] : Change threshold. 

[Width]  : Target data length. 

Determines whether the amount of change between these lengths is 

within the threshold. Data subject to noise is deleted, and linear 

interpolation is performed from neighboring values 

 

 

Example of Variation Cut-Off Filter 

 

In this case, the filters are applied four times repeatedly, with the temporal change 

being threshold=0.1 and 0.3 - 0.8sec selected in the 2D area. Only noise within the 

range has been removed. 
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 Saving Filter Data 

In the Filter Control dialogs for filter settings, the set filter is registered in the filter 

area. You can create multiple filters in the Filters area, and when you execute them, 

they are filtered in order from the beginning. 

 

6.7.6.1. Procedure for saving filter data 

Enter an output filename in [Output Filename] and select [Run] to perform filtering and 

save the data obtained by filtering. After saving, the 3D graph with the new data starts. 

 

 

[Output Filename] : Enter the folder name and file name to save. The output file 

is a text file (.txt) or a CSV file (.csv). 

[Add] : Add a new filter. 

[Edit] : Edits the filter selected in the filter area. 

[Delete] : Deletes the filter selected in the Filters area. 

[Clear] : Deletes all filters in the filter area. 

Up / Down : Changes the order of the selected filters. Filters usually come 

from top to bottom. 

[Run] : Executes the filter, outputs the file, and launches a new 

three-dimensional graph. 
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 Temperature Conversion Tool 

The F3D Temperature Conversion Tool (Spectral Shift to Temperature Tool) is an 

application tool that aims to convert spectral shift measurement data into temperature 

data. 

By converting the measurement data of spectral shift to temperature using the tool's 

unique temperature coefficient, it is able to output appropriate temperature. It is also 

useful when you perform temperature compensated measurements. 

 

7.1. Launch Temperature Conversion Tool 

Right-click in the F3D 3Dviz Model View area and click Launch SpectralShift to 

Temperature Tool. 

 

 

The temperature conversion tool consists of six parts: "input file", " output file", "fiber 

type", "reference temperature", "force processing selection" and "Run button". 

You can also check the software version by clicking "About" in the upper left corner. 
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7.2. Select input data 

Click [Input spectral shift file ...] and select the Spectral shift measurement file that you 

want to convert to temperature. 

 

 

There are three types of measurement data that can be specified: TSV file, text file, 

and CSV file. Use the data exported from ODiSI controller for TSV files, and the data 

exported from F3D Filter Tool for text files and CSV files.  

 

7.3. Select output destination 

Click [Output temperature file ...] and specify the output destination and file name of 

the measurement data converted to temperature. 

 

The output file format can be specified from two types, text file and CSV file. 

 

7.4. Select Fiber Type 

Select Polyimide if using polyimide coated fiber in the Fiber Type pull-down menu, or 

select Gold if using gold coated fiber.  
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7.5. Enter Reference Temperature 

Enter the reference temperature in [Reference Temperature]. The unit is Celsius. 

 

Enter the ambient temperature at the start of normal measurement as the reference 

temperature. If you want to know only the amount of temperature change, enter 0. 

 

Note: 

The temperature coefficients used in this tool is the best match when the reference 

temperature is approximately 25 degrees Celsius.  

 

7.6. Run Conversion Process  

Click Run to start the conversion process and a message will appear when the 

process is complete. 

     

 

Note:  

When [Enable Force Processing] is checked, if the input file contains “NAN”,  NAN is 

replaced with a very large value (about 10e+38) to perform automatic conversion.  
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Software update log 

V2.0.0 change 

Change the GUIs in the FBI-G Main Window 

Modify the Filter Tool and Temperature Conversion Tool to Start From the 

Menu Tab 

Change Shortcut Buttons 

Adding the Save and Read Views Function 

Addition of STL Temperature Interpolation Contour Display Function 

Eliminate numerical adjustments by wheel to input text 

(Contour Up/Down Limit, Fiber Position, Fiber Width, etc.) 

Change fiber position data extension from.txt to.fld 

Supports measurement result files containing "1.#QNAN" outputted from the 

ODiSI-B. 

The filter tool supports measurement result files with unequal time intervals. 

Fixed a Bug in the Filter Tool where the Delete Last Row Duplicate Operation 

Does Not Delete the Last Row (Filter Tool) 

Modified so that the interpolated values of the cut-off filter and the change 

amount cut-off filter become values depending on the distance. 

Fixed a bug that dropped when the drawing screen was narrowed 

Addition of cross section graph csv output function in the filter tool 

 

V2.0.1 Changes 

Change the coefficients for polyimide fiber in the temperature conversion tool. 

Enables you to select either fixed-value substitution or pre-and-post 

interpolation when reading measurement result files containing "1.#QNAN" 

from the ODiSI-B. 

Changing 

Temperature-conversion tools add forced run options for measurement result 

files containing last line duplicates and 1.#QNAN. 

 

V2.0.2 Changes 

Change the scale setting for a graph in the Filter tool 

Add movie output function (.avi) 
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V2.0.3 Changes 

Supports 100MB or more files for reading ODiSI measurement data 

V2.0.4 Changes 

Added size fixation function for model view 

Image Format and Image Size Settings for Continuous Image Output 

Add compression setting in movie power 

Addition of cross section graph txt output function in the filter tool 

Change the low-pass filter to continuous executable. 

 

V3.0.0 change 

Supports ODiSI 6100 Series 

Add Fiber Route Settings and Output Modes 

 

V3.0.1 Changes 

Fixed Fiber Route Configuration Listing 

 

V3.0.2 Changes 

Added function to interpolate fiber position information 

 

V3.1.0 Changes 

Add 2D Contour Function to 3Dviz 

Changed to transparently show NANs in 3Dviz 

Changes to allow you to select the type of contour in the 3Dviz (HSV, JET, 

HOT, COLD) 

Adding a Contour Bar view in the 3Dviz 

Changed to ignore NANs when fitting in 3Dviz graphs 

Supports ODiSI 6100 v1. 6 outputs 

Supports measurement data for a plurality of channels in 3Dviz 

Play Back function and movie creation function are added to 3Dviz. 

Supports binary STL data 

Addition of saving and loading of View in 3Dviz 

Changed so that view operations cannot be performed while Ctrl keys are 

pressed on the 3Dviz. 

Fixed a bug when creating fiber routes 

Change licensing system 
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V3.1.1 Changes 

Supports tsv files exported by ODiSI v1. 6.1 

 

V3.2 Changes 

Conversion tool is added. (SpectralShift to Temperature Tool) 

 

V3.2.1 Changes 

Fixed a bug related to data reading during real-time visualization 

 

V3.3 Changes 

Added transparency and wireframe display to Tria Setting 

Fixed a bug related to real time measurement data plotting 

 


